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Error on syncing new customers' orders to MYOB Accountright Live

DESCRIPTION

If your site is configured to:
- send new customers through to your MYOB Accountright Live (ARL)
- create a new debtor card
- and assign that new debtor account number to the online profile

You may occasionally see an error on the corresponding  sales order that looks like:
The error message received was: CommonRules_StringRequired

EXTRA INFO

This error message is rather generic and potentially confusing - however it essentially refers to one or more mandatory fields in MYOB that haven't been filled-out on the customer's online profile.
This is only really going to happen with new customers, you shouldn't see this error with any existing customers.

RESOLUTION

Edit the customer's details in the CMS of the site and make sure all fields that are mandatory debtor card fields in MYOB ARL are also filled-out online in their online profile.
(alternatively, you could make those fields NON-mandatory in your ARL).

NOTE: whichever fields are mandatory is subjective on a customer-by-customer basis as not all our ARL customers will have the same fields set as mandatory on MYOB's end.

Once their details are updated - wait until the next sync runs before checking if it's synced correctly.
Once the customer's details have synced to ARL, and their MYOB  debtor card ID has been synced back to their online profile - THEN their order should activate to sync to MYOB.
Until that happens - the order will sit in "pending" status online and won't sync to MYOB

 

CAUSE

Some fields in MYOB are required/mandatory fields and if that data is missing, MYOB won't allow it to sync or create a debtor account; so the online data has to match MYOB's requirements first before we can sync the corresponding order through to their debtor account in MYOB.