SYMPTOM
Most of your products display correctly on the site, but a handful of products have missing or partial data - most commonly an issue with long product descriptions. This can come in the form of a broken sentence or even a word cut in half. Especially seen when there's a word ending in " 's" but can be found in any other seemingly random parts of data.
Secondary Symptoms
This may also be coupled with other issues, such as broken functionality on the product, eg. missing attributes, attributes like "new" or "featured" may no longer work - that are reliant on data in product attribute fields - in WN's system these are referred to as "user fields" or "Product Fields".
This symptom is generally quite rare, and almost always confined to integrations that use .CSV's to import product data - although this has been witnessed as happening in data coming directly from some accounting packages.
CAUSE
The cause is due to invalid data/ text stored in the affected field - which in most systems, applications and web browsers is invisible or may simply appear as just a space - effectively making it undetectable.
These characters can cause issues with how the data is imported into the online database as databases have certain requirements, including the need to handle text as standard web UTF-8 format.
Where do these characters come from? Most commonly copied from original product data sheets like PDFs, word documents, other websites or even out of a supplier's own original spreadsheet.
RESOLUTION
To resolve this "dirty data" it needs to be "cleaned" of these erroneous characters.
Even if you can't see them, you can see their effect, which tells you which field is affected in either your spreadsheet or your Accounting software.
The simplest way to 'clean' the data is to copy ALL of the affected text from the field in the spreadsheet, or out of your accounting software, and paste it into notepad (it must be notepad, not MS Word or Wordpad, only notepad will work) and then highlight it and copy it back out again from Notepad and paste it back into the spreadsheet or accounting software field.
You'll then need to let the data sync back up to Webninja (or if you're using Webninja's first generation sync software, make sure to run an import first, then the sync) before checking it online.
PREVENTION
It's generally recommended to follow these steps above or similar when copy/pasting product data at the time of creating the product in your accounting software. There are several online services and tools easily found via a quick Google search for "cleaning special characters from spreadsheet data" or similar keywords.