SYMPTOM
You receive payment in your credit card Payment Gateway (eg. Securepay, Paypal, DPS etc.) but there's no order created in the CMS back-end of the website and nothing imports to your accounting software.
COMMON CAUSES:
This issue generally happens when the website has sent the order details to the payment gateway and is awaiting a response from the payment gateway to confirm the payment was successful.
If there's anything that prevents the payment gateway from responding to your website or if it times-out in sending the response back (eg. due to net congestion or sometimes the payment gateway's own servers could be slow to respond on some days) - then the website sits in limbo waiting for a response.
It can't create or confirm an order as successful if the payment gateway never confirms the payment.
NOTE: time-out times can vary from one payment gateway to another and may or may not be a value that can be altered in your payment gateway settings when you log into your payment gateway.
RESOLUTION/WORKAROUND:
Web Ninja has created a temporary orders module that stores order details for customers who have added items to the cart and started the checkout process, but it never was created as an order. If you can't find this option in your CMS - please contact Webninja Support to see if they can activate it for you.
This can happen for multiple reasons:
- the customer changed their mind and stopped the checkout process
- the customer decided to save their cart for later
- the customer started to check out but remembered they wanted to add something else to the cart first
- the order was submitted to the payment gateway, but we never received confirmation the payment was successful
From the temporary orders module, you can cross-reference the payments you've received with the details of the temporary orders and if they match, convert the temporary order to a live order that will go into the queue of orders same as the rest of your orders.
Q: Why can't Web Ninja just fix the payment issue with the payment gateway?
A: Due to the nature of the cause - being that there are numerous external factors that affect our communication to the payment gateway and as the payment gateway itself is a 3rd party - we cannot 100% control all those factors as they're outside our control.
If we were to increase the timeout at our end to a much longer time, multiple issues would arise from that:
- very long wait times for your customers trying to checkout
- the website could potentially crash if all the orders are waiting for a response that will never happen - so we need to put some kind of time limit on it to minimise these symptoms
For more information about using the Temporary Orders module - please see this article:
ARTICLE: Find Missing Orders With Webninja's Temporary Orders Module
NOTE: This article is only relevant to Web Ninja's Current Generation websites.
If your site was created before that time, it may be possible to implement a temporary orders option, but you will need to contact Webninja support and request that this option is scoped for feasibility and a quote may be required to have it added.