DESCRIPTION
You might see an order in your list of orders in the CMS that's highlighted in red, and when you open or edit the order, you find it has a red message above the order that says:
Connection not completed before timeout at WebNinja
EXTRA INFO
This error can happen either randomly when trying to sync orders to Fishbowl, while other orders randomly sync ok; or you might find it happens with every order placed since a specific time.
This error happens when your Fishbowl is inaccessible for any number of reasons (eg. it could be something affecting access to Fishbowl's database, or it could just simply be something happening in the Fishbowl server preventing access altogether).
SOLUTION - HOW TO FIX
- To attempt to resync the orders to your Fishbowl, please follow the steps in this article:
My order didn't import into my Accounting package
- in our experience - this most often resolves this issue as this error more often than not appears to be temporary
- unless you're experiencing every order has errored over an extended period of time (many hours/days) - Failing that - please review when the errors first started happening (or if they appear to be random, see if they consistently happen around the same time of day regularly?)
- restart your Fishbowl server and follow step 1 above
if that doesn't work... - follow-up with your Fishbowl partner and see if they can see an activity or action happening in your Fishbowl consistently at the same time of day that coincides with when these errors happen
- If your Fishbowl partner is unable to determine any type of consistent action or activity that happens at the same time as the errors - please follow-up with your IT to see if they can see anything happening on your network, servers, Internet etc. at those times that might affect any type of connectivity to your Fishbowl.
- After each of the above steps, you'll need to follow the instructions in Step 1 to resync the errored orders
- restart your Fishbowl server and follow step 1 above
If after following all these steps you're still getting this error - please contact Webninja support for further help.
PLEASE NOTE: if you haven't followed all these steps first before you contact support, our support team will still require you to follow these steps - so it's best if you complete these steps first to save yourself some time.
CAUSE
This error has been observed to be related to issues happening on your local server where your Fishbowl server is installed, not on Webninja's servers. Please follow all the steps outlined above.